summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 55 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbb328fc9cee..66583c1f9d6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,68 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
+# Maintainer: Grey Christoforo <first name at last name dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
_cranname=withr
-_cranver=2.4.3
+_cranver=3.0.0
pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="Run Code 'With' Temporarily Modified Global State"
-arch=(any)
+pkgdesc="Lightweight Well-Known Geometry Parsing"
url="https://cran.r-project.org/package=${_cranname}"
-license=(MIT)
-depends=('r>=3.2.0')
-optdepends=(r-callr r-covr r-dbi r-knitr r-rmarkdown r-rsqlite r-testthat)
+license=("MIT")
+pkgver=${_cranver//[:-]/.}
+pkgrel=2
+
+arch=("any")
+depends=(
+ "r>=3.2.0"
+)
+optdepends=(
+ "r-callr"
+ "r-covr"
+ "r-dbi"
+ "r-knitr"
+ "r-rlang"
+ "r-rmarkdown>=2.12"
+ "r-rsqlite"
+)
+
+# The unittests for `r-withr` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-withr`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# "texlive-core"
+# )
+
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('9bdac7459ccc6c2d599ecfd132a7f0aa68d958942d9fe7dbb0442c9eda129d4c')
+b2sums=("12ee381cbd50dfc7f2e1395d061bac5879e40c12f87a5952706987634ba097d7dd93854ed2997e81d5f18fa5b63508d550379652df4326914b42cd0aebb94968")
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p "${srcdir}/build/"
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
}