summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d98d92f543d..8a81436b30d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Contributor: Simon Kohlmeyer <simon.kohlmeyer@googlemail.com>
pkgname=rbenv-git
-pkgver=1.2.0.r14.gc6cc0a1
+pkgver=1.2.0.r46.g52acbdf
pkgrel=1
pkgdesc="Simple Ruby version manager"
-arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+arch=('any')
url="https://github.com/rbenv/rbenv"
license=('MIT')
depends=('bash')
@@ -18,12 +18,6 @@ source=('git+https://github.com/rbenv/rbenv.git')
sha256sums=('SKIP')
-build() {
- cd "${pkgname%-git}"
- src/configure
- make -C src
-}
-
pkgver() {
cd "${pkgname%-git}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
@@ -34,10 +28,8 @@ package() {
install -Dm 644 ./LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
- # mkdir -p "$pkgdir/usr/lib/rbenv/completions/"
install -Dm 644 -t "$pkgdir/usr/lib/rbenv/completions/" ./completions/*
- # mkdir -p "$pkgdir/usr/lib/rbenv/libexec/"
install -Dm 755 -t "$pkgdir/usr/lib/rbenv/libexec/" ./libexec/*
install -d "$pkgdir/usr/bin/"