summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9c73288fb57..8099eae3de76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Samo Turk <samo.turk@gmail.com>
pkgname=rdkit-python2
_pkgname=RDKit
-pkgver=2018_09_1
+pkgver=2019_03_1
pkgrel=1
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
url="http://rdkit.org/"
license=('New BSD License')
-depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairocffi' 'python2-pillow' 'inchi' 'eigen3')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairo' 'python2-pillow' 'eigen3')
source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz")
-sha256sums=('61c14652a05a6f6b216ff099381c4dd32048861ba9d96f75a017084e81848baa')
+sha256sums=('41d0d9b82daaca8662b269096361577537fe098176c7da9cf5301c42d2f2068e')
provides=('rdkit')
conflicts=('rdkit' 'rdkit-git')
@@ -22,8 +22,8 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7/ \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
- -DRDK_BUILD_INCHI_SUPPORT=ON
+ -DPYTHON_EXECUTABLE=/usr/bin/python2
+# -DRDK_BUILD_INCHI_SUPPORT=ON
make
}