summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 62d2786aedd0..4ad46df0f7c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,20 @@
pkgname=rdkit-python2
_pkgname=RDKit
pkgver=2018_03_2
-pkgrel=1
+pkgrel=2
pkgdesc="RDKit - A collection of cheminformatics and machine-learning software written in C++ and Python."
arch=("i686" "x86_64" "armv7h")
url="http://rdkit.org/"
license=('New BSD License')
-depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairocffi' 'python2-pillow')
-source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz" "http://www.inchi-trust.org/download/105/INCHI-1-SRC.zip")
-sha256sums=('29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed'
- '4ac311ca3a16fa75d695ec4fc711e74045c6d6c882dea0dd1055961fba643720')
+depends=( 'bison' 'boost' 'boost-libs' 'cmake' 'flex' 'python2' 'python2-numpy' 'sqlite3' 'python2-cairocffi' 'python2-pillow' 'inchi')
+source=("https://github.com/rdkit/rdkit/archive/Release_${pkgver}.tar.gz")
+sha256sums=('29eeba93e723f0f9d61e31cf0f89ec18ba942a7f9e416dbc1a92122fce08cbed')
provides=('rdkit')
conflicts=('rdkit' 'rdkit-git')
build() {
- cd ${srcdir}
- mkdir build
- mkdir -p rdkit-Release_${pkgver}/External/INCHI-API/src
- cp -a INCHI-1-SRC/* rdkit-Release_${pkgver}/External/INCHI-API/src
- cd build
- cmake ../rdkit-Release_${pkgver} \
+ cd ${srcdir}/rdkit-Release_${pkgver}
+ cmake . \
-DCMAKE_BUILD_TYPE=Release \
-DRDK_INSTALL_INTREE=0 \
-DCMAKE_INSTALL_PREFIX=/usr \