summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44771e52de9f..f525540ad199 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: arshlinux
pkgname=react-deluge-git
pkgver=r9.77417a8
-pkgrel=2
+pkgrel=3
pkgdesc="The very first React Front-end for the Deluge BitTorrent client"
url="https://github.com/varyoo/react-deluge"
license=(GPL3)
arch=(x86_64)
depends=()
-makedepends=(git npm)
+makedepends=(git npm electron)
optdepends=()
backup=()
source=("git+https://github.com/varyoo/react-deluge")
@@ -33,10 +33,12 @@ build() {
package() {
cd "${srcdir}/react-deluge"
- # Install the application
- install -d ${pkgdir}/{opt,usr/bin}
- cp -a "${srcdir}/react-deluge/builds/react-deluge-linux-x64" "${pkgdir}/opt/react-deluge"
- ln -s "${pkgdir}/opt/react-deluge/react-deluge" "${pkgdir}/usr/bin"
+ install -d ${pkgdir}/{opt/react-deluge,usr/bin}
+
+ cd "${srcdir}/react-deluge/builds/react-deluge-linux-x64"
+ cp -a * "${pkgdir}/opt/react-deluge"
+
+ ln -s /opt/react-deluge/react-deluge "${pkgdir}/usr/bin"
# npm gives ownership of ALL FILES to build user
# https://bugs.archlinux.org/task/63396