summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 217e1dd34c50..836591a788fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgver() {
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
pkgver=r134.66c12ce
-pkgrel=1
+pkgrel=2
pkgdesc='A command-line interface for Reddit written in POSIX sh'
arch=('any')
@@ -16,19 +16,21 @@ license=('custom:MIT')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-depends=('curl' 'jq')
+depends=('dash' 'curl' 'jq')
optdepends=('gnu-netcat: authenticate with your Reddit account credentials'
'openbsd-netcat: authenticate with your Reddit account credentials')
makedepends=('git')
changelog=ISSUES
-source=("git+$url")
-sha256sums=('SKIP')
+source=("git+$url" 'archlinux.patch')
+sha256sums=('SKIP' 'd56a36a70ea279778a60e8b827c80166189584dce54bdeeccb8f33a047419157')
prepare() {
cd "${pkgname%-git}"
- # Arch packages are never ever installed to /usr/local/
- sed -i 's|/usr/local/|/usr/|g' "${pkgname%-git}"
+ # Bash's printf statement may fail when using `.` as decimal point under
+ # certain locales, so for the time being we set `LC_ALL` to `C`.
+ # Also, Arch packages are never ever installed to `/usr/local/`.
+ patch -Np1 <../archlinux.patch
}
package() {