summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 18 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dec9f458d0af..eb9d0861ebee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=requestly-git
_pkgname=Requestly
-pkgver=1.6.0.r6.g861adb6
-_electronversion=23
-_nodeversion=16
+pkgver=1.6.0.r12.g5a392b0
+_electronversion=27
+_nodeversion=18
pkgrel=1
pkgdesc="Debug your network request across all platforms and browsers using a single app"
arch=('x86_64')
@@ -14,7 +14,6 @@ license=('AGPL-3.0-only')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
depends=(
- 'hicolor-icon-theme'
"electron${_electronversion}"
)
makedepends=(
@@ -32,10 +31,10 @@ source=(
)
sha256sums=('SKIP'
'SKIP'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '2b2e8aeed33fd71c521e49fd54fb2fa81218d16aef8bccb88d77909055ab8051')
pkgver() {
cd "${srcdir}/${pkgname//-/.}"
- git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g'
}
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
@@ -47,37 +46,31 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-git}|g" \
-e "s|@appasar@|app.asar|g" \
+ -e "s|@cfgdirname@|${_pkgname}|g" \
-e "s|@options@||g" \
-i "${srcdir}/${pkgname%-git}.sh"
_ensure_local_nvm
- gendesk -f -n -q --categories="Development" --name="${_pkgname}" --exec="${pkgname%-git} %U"
+ gendesk -f -n -q --pkgname="${pkgname%-git}" --pkgdesc="${pkgdesc}" --categories="Development" --name="${_pkgname}" --exec="${pkgname%-git} %U"
export npm_config_build_from_source=true
export npm_config_cache="${srcdir}/.npm_cache"
- export ELECTRON_SKIP_BINARY_DOWNLOAD=1
- export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')"
- export npm_config_target="${SYSTEM_ELECTRON_VERSION}"
- export ELECTRONVERSION="${_electronversion}"
- export npm_config_disturl=https://electronjs.org/headers
+ #export ELECTRON_SKIP_BINARY_DOWNLOAD=1
+ #export SYSTEM_ELECTRON_VERSION="$(electron${_electronversion} -v | sed 's/v//g')"
+ #export npm_config_target="${SYSTEM_ELECTRON_VERSION}"
+ #export ELECTRONVERSION="${_electronversion}"
HOME="${srcdir}/.electron-gyp"
- cd "${srcdir}/${pkgname%-git}-proxy"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_disturl=https://registry.npmmirror.com/-/binary/node/
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
else
echo "Your network is OK."
fi
+ cd "${srcdir}/${pkgname%-git}-proxy"
npm install
cd "${srcdir}/${pkgname//-/.}"
- if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
- else
- echo "Your network is OK."
- fi
- sed "s|--publish never|--dir|g;s|icon.icns|icon.png|g" -i package.json
- sed "s|iconTemplate.png|..\/..\/..\/${pkgname%-bin}\/assets/iconTemplate.png|g" -i src/main/main.ts
+ sed "s|AppImage|dir|g;s|icon.icns|icon.png|g" -i package.json
+ sed "s|process.resourcesPath|\"\/usr\/lib\/${pkgname%-git}\"|g" -i src/main/main.ts
npm install
npm run package
asar e "${srcdir}/${pkgname//-/.}/release/build/linux-unpacked/resources/app.asar" "${srcdir}/app.asar.unpacked"