summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3142e9086b83..b0190aec5762 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
# Maintainer: Vanya A. Sergeev <v@sergeev.io>
pkgname=rigexpert-tool
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Dump, plot, and convert impedance sweeps from a RigExpert antenna analyzer"
arch=('any')
url="https://github.com/vsergeev/rigexpert-tool"
license=('MIT')
depends=('python-pyserial' 'python-matplotlib' 'python-scipy')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
source=("git+https://github.com/vsergeev/rigexpert-tool.git#tag=v$pkgver")
md5sums=('SKIP')
+build() {
+ cd "$pkgname"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$pkgname"
- install -D -m 0755 rigexpert_tool.py "$pkgdir/usr/bin/rigexpert-tool"
- install -D -m 0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}