summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 27 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 706038e9101a..b40bfac997fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,46 @@
-# Maintainer: Pierre Choffet <peuc@wanadoo.fr>
-
-# Note: unlike the ring-daemon-git and libringclient-git, this package doesn't
-# use pinned commit, so you may encounter some compatibility issues with lower
-# level librairies if their packages are not updated. In this case, just append
-# #commit=<commit_id> in source url.
-
-pkgname=ring-kde-git
-pkgver=2.0.0.r269.g910e74e
+#!/bin/bash
+# shellcheck disable=SC2034,SC2164
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Pierre Choffet <peuc@wanadoo.fr>
+_pkgname=ring-kde
+pkgname=$_pkgname-git
+pkgver=2.0.0.r626.g7790658e
pkgrel=1
-pkgdesc="KDE client for Ring"
-arch=("i686" "x86_64")
-url="http://ring.cx/"
-license=("GPL3")
-groups=("ring")
-depends=("libringclient-git" "knotifyconfig" "hicolor-icon-theme")
-makedepends=("git" "extra-cmake-modules" "python" "glu" "kinit")
-provides=("ring-kde")
-conflicts=("ring-kde")
+pkgdesc="The KDE client for the Ring communication framework (www.ring.cx)"
+arch=('x86_64')
+url="https://ring.cx/"
+license=('GPL')
+groups=('ring')
+depends=('libringqt' 'knotifyconfig' 'kdeclarative' 'kirigami2')
+makedepends=('git' 'extra-cmake-modules' 'kdoctools')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
changelog="ChangeLog"
-source=("git://anongit.kde.org/ring-kde")
-sha256sums=('SKIP')
+source=('git://anongit.kde.org/ring-kde.git')
+md5sums=('SKIP')
pkgver() {
- cd "ring-kde"
+ cd "$_pkgname"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "ring-kde"
+ mkdir -p build
# fix missing tray icon
- sed 's|setIconByPixmap(.*);|setIconByName("ring-kde");|' -i src/widgets/systray.cpp
+ sed -i 's/setIconByPixmap(.*);/setIconByName("ring-kde");/' \
+ "$_pkgname"/src/widgets/systray.cpp
}
build() {
- cd "ring-kde"
-
- mkdir -p build
cd build
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
-
+ cmake ../"$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd "ring-kde/build"
+ cd build
+ # shellcheck disable=SC2154
make DESTDIR="$pkgdir" install
}