summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d02f9048ce0..3c7be4f1ba0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,12 @@
# Maintainer: Daniel Langbein <daniel@systemli.org>
pkgname="riseup-vpn-terminal"
-pkgver=0.0.4
-pkgrel=2
+pkgver=0.0.5
+pkgrel=1
pkgdesc="Script and desktop entry to start RiseupVPN in a terminal; useful when desktop environment does not support tray icons (e.g. GNOME, Phoc)"
arch=('any')
license=('MIT')
depends=('riseup-vpn')
-depends+=('curl') # see riseup-vpn-terminal script
# This is required for e.g. the PinePhone where otherwise
# no polkit agent is running. See this issue:
@@ -16,14 +15,14 @@ optdepends+=('lxqt-policykit: Provides a policykit agent. Usually one is started
source=('riseup-vpn-terminal' \
'riseup-vpn-terminal.desktop')
-sha256sums=('a3c81910c00fc91c77538b5f2a48b92ac3aba3915b88e67880ecbcdae8daaec0' \
+sha256sums=('b5aaee2201383fbb42d1c020319239219f493f613ce4120101df657b9e4cf500' \
'8f77468d7852b489a6b1ff4c88272e3aee50af49d7e36341bf1677e872e5aecb')
package() {
install -Dm0555 riseup-vpn-terminal "$pkgdir"/usr/bin/riseup-vpn-terminal
install -Dm0644 riseup-vpn-terminal.desktop "$pkgdir"/usr/share/applications/riseup-vpn-terminal.desktop
- # Uncomment the line below when using KGX as the only terminal (e.g. on PinePhone with Phosh)
+ # Uncomment the line below when KGX is the only installed terminal (e.g. on PinePhone with Phosh)
# See also: https://github.com/dreemurrs-embedded/Pine64-Arch/issues/182
- #ln -sf /usr/bin/kgx "$pkgdir"/usr/bin/konsole
+ #ln -sf /usr/bin/kgx "$pkgdir"/usr/bin/dtterm
}