summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89203fd77db4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+_pkgname=octomap_msgs
+pkgname=ros2-humble-octomap-msgs
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Messages and serializations / conversion for the OctoMap library."
+url="https://index.ros.org/p/octomap_msgs/"
+arch=('any')
+depends=('ros2-humble')
+source=("https://github.com/OctoMap/$_pkgname/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('ef273be4b931eacce289ec664a0515d215e1970954d7818df3151e0f2aa90735')
+
+build() {
+ source /opt/ros/humble/setup.bash
+
+ cmake -B build -S "$_pkgname" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/opt/ros/humble' \
+ -Wno-dev
+
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}