summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18dd015b6cc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andreas Louv <andreas@louv.dk>
+
+pkgname=rpglectags-git
+pkgver=1.7.1
+pkgrel=1
+pkgdesc="Create tags files from ILE RPG source files."
+arch=("any")
+url="https://github.com/andlrc/rpglectags"
+license=("PerlArtistic")
+depends=("perl>=5.16")
+makedepends=("git")
+provides=("rpglectags")
+source=('rpglectags::git+git://github.com/andlrc/rpglectags#branch=master')
+md5sums=("SKIP")
+
+pkgver()
+{
+ cd "$srcdir/${pkgname%-git}"
+ sed '/our \$VERSION.*'\''\(.*\)'\''.*/{s//\1/;q};d' rpglectags
+}
+
+package()
+{
+ cd "$srcdir/${pkgname%-git}"
+ install -D rpglectags $pkgdir/usr/bin/rpglectags
+ install -Dm644 rpglectags.1 $pkgdir/usr/share/man/man1/rpglectags.1
+}