summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05e08d212420..bb3da33bff88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Ian Douglas Scott <ian@iandouglasscott.com>
pkgname=rpython
-pkgver=0.1.4
-pkgrel=2
+pkgver=0.2.1
+pkgrel=1
pkgdesc="Restricted python compiler"
url="http://pypy.org"
arch=('any')
depends=('python2' 'python2-setuptools' 'python2-pytest')
license=('MIT')
source=("https://pypi.python.org/packages/source/r/rpython/rpython-${pkgver}.tar.gz")
-md5sums=('680fcee2fed5f94fcb4390130510eec9')
+md5sums=('07b38960ceb4ae9bb10ab99ceedef888')
prepare() {
cd ${pkgname}-$pkgver
@@ -17,7 +17,12 @@ prepare() {
sed -i "s|os.path.realpath(os.path.join(MAINDIR, '_cache'))|os.path.expanduser('~/.cache/rpython')|" rpython/config/translationoption.py
}
+build() {
+ cd ${pkgname}-$pkgver
+ python2 setup.py build
+}
+
package() {
cd ${pkgname}-$pkgver
- python2 setup.py install --root="${pkgdir}" --optimize=1
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}