summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28765206c486..a6ac6c370a92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
_pkgbase=rtl8xxxu
pkgname=rtl8xxxu-dkms-git
-pkgver=r25.a029f77
+pkgver=r27.972686d
pkgrel=1
-pkgdesc="Driver for Realtek RTL8XXXXU usb wifi chips"
+pkgdesc="Driver for Realtek 802.11n USB wireless chips"
arch=('any')
url="https://github.com/a5a5aa555oo/rtl8xxxu"
license=('GPL2')
depends=('dkms' 'linux-firmware>=20230625.ee91452d-1')
makedepends=('git')
-source=("git+https://github.com/a5a5aa555oo/rtl8xxxu.git")
+source=("git+https://github.com/a5a5aa555oo/rtl8xxxu")
sha256sums=('SKIP')
-optdepends=('usb_modeswitch: For RTL8188GU/RTL8192FU users, use this to switch the dongle to wifi mode if needed.')
+optdepends=('usb_modeswitch: For RTL8188GU/RTL8192FU users, use this tool to switch the adapter to wifi mode if needed.')
prepare() {
cd "${srcdir}"/${_pkgbase}
- sed -i "/POST_INSTALL/d" dkms.conf
+ sed -e "/POST_INSTALL/d" -e "/PACKAGE_VERSION/d" -i dkms.conf
+ printf "PACKAGE_VERSION=\"@PKGVER@\"\n" >> dkms.conf
echo "blacklist rtl8xxxu" > blacklist-rtl8xxxu.conf
echo "options rtl8xxxu_git ht40_2g=1" > rtl8xxxu_git.conf
}
@@ -30,5 +31,5 @@ package() {
cd "${srcdir}"/${_pkgbase}
install -Dm 644 -t "${pkgdir}"/etc/modprobe.d blacklist-rtl8xxxu.conf rtl8xxxu_git.conf
install -Dm 644 -t "${pkgdir}"/usr/src/${_pkgbase}-${pkgver} *.c *.h Makefile dkms.conf
- sed -e "s/git_4831a80-1/${pkgver}/" -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+ sed -e "s/@PKGVER@/${pkgver}/" -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
}