summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8da2e6cac60f..cd7c5fb49841 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,14 @@ url="http://www.music.mcgill.ca/~gary/rtmidi/"
license=('MIT')
depends=('jack')
source=("${url}release/${pkgname}-${pkgver}.tar.gz"
- '0001-tests-Makefile.in.diff')
+ '0001-fix-tests-with-prefix.diff')
sha512sums=('b5cba769e4641ac453493e2e6ca6f947d7ef5fe71870dd10aa19c93ad18dd62ed01358c468c0e1e326dbc29bd00ecc32b9d8895276d9f46e9e0aa20ed6e0b70f'
- '64a3a50b1049e76dd28e7a6cde45cbd6fba2e4d94ed42d34c333030963befc20bff8d9d7cc644a06438a8f9f2d43be663a8b6ebfe55f96d22b796a044bafb193')
+ 'b45156fd1fca578a0952f3819ffe5721b57e8e8237ba3b532bad0349e201bcfc75460d4d393b3233dacbc994be71186e72f2ae475ac97053ef51716e9f7ba99a')
prepare() {
- # Link the tests against build output and not the system library.
- patch -Np1 -i 0001-tests-Makefile.in.diff
+ # Link the tests against build output and not the system library when using --prefix.
+ # [https://github.com/thestk/rtmidi/pull/127]
+ patch -Np1 -i 0001-fix-tests-with-prefix.diff
}
build() {