summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90cdf71ac058
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=rtop-git
+pkgver=1.0+5.gc49441bc1f
+pkgrel=1
+pkgdesc="Interactive, remote system monitoring tool based on SSH"
+url=http://rtop-monitor.org
+license=(MIT)
+arch=(x86_64)
+source=('git+https://github.com/rapidloop/rtop')
+sha256sums=('SKIP')
+makedepends=("go")
+
+pkgver() {
+ git -C rtop describe --abbrev=10 |
+ sed 's/^release_//; s/-/+/; s/-/./'
+}
+
+build() {
+ export GOPATH="$srcdir"
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
+ go get github.com/rapidloop/rtop
+}
+
+package() {
+ install -Dm755 bin/rtop "$pkgdir"/usr/bin/rtop
+}