summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a4cf8f82aa2..fd37b3047e0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tim van Leuverden <TvanLeuverden at Gmail dot com>
pkgname=ruri
-pkgver=2.0.1
+pkgver=2.1.0
pkgrel=1
pkgdesc="Calculates the CRC-32 of files and checks them against their filename"
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
@@ -19,17 +19,20 @@ source=(
)
sha256sums=(
- 'ef7883661b0f145b6bf9b7d6be172b2c17198003625f28ce7950065d489f5a20'
+ '30ce2f395e3bfcf4891ef544f139d072466b8fff00b832a02d32bed4aa952f49'
)
build() {
cd "${srcdir}/${pkgname}-v${pkgver}"
-
+ export CARGO_REGISTRIES_CRATES_IO_PROTOCOL=sparse
cargo install --locked --no-track --bin ruri --path . --root "${srcdir}"
}
package() {
- install -Dm755 "${srcdir}/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 "${srcdir}/bin/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-v${pkgver}"/target/release/build/ruri-*/out/ruri.* \
+ -t "${pkgdir}/usr/share/man"
}
# vim: sw=2 ts=2 tw=80 et: \ No newline at end of file