summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 3 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80f1a8abbe8a..5dbbcc8e35a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=rust_hdl-git
_pkgname=rust_hdl
-pkgver=v0.19.0.r0.gdd25382
+pkgver=v0.22.0.r14.g57a420f
pkgrel=1
pkgdesc="A collection of of HDL related tools"
arch=('i686' 'x86_64')
@@ -10,10 +10,8 @@ url="https://github.com/VHDL-LS/rust_hdl"
license=('MPL2')
makedepends=('git' 'rust')
provides=("rust_hdl=${pkgver}")
-source=("git+https://github.com/VHDL-LS/${_pkgname}.git"
- "installed.patch")
-sha256sums=('SKIP'
- '0b237e7a6a8b66f77c3f7f1c19b214f6ef711290d67a4c9fa9acfe4fee1c3f05')
+source=("git+https://github.com/VHDL-LS/${_pkgname}.git")
+sha256sums=('SKIP')
pkgver()
{
@@ -24,11 +22,6 @@ pkgver()
printf "%s.r%s.g%s" "${_tag}" "${_rev}" "${_hash}" | sed 's/^rust_hdl-//'
}
-prepare()
-{
- patch --directory="${_pkgname}" --forward --strip=1 --input="${srcdir}/installed.patch"
-}
-
check()
{
cd "${_pkgname}"
@@ -46,14 +39,12 @@ package()
cargo install \
--no-track \
--locked \
- --features "installed" \
--root "${pkgdir}/usr" \
--path .
cd "${srcdir}/${_pkgname}/vhdl_ls"
cargo install \
--no-track \
--locked \
- --features "installed" \
--root "${pkgdir}/usr" \
--path .
}