summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dae55620d6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=rustfilt
+pkgrel=1
+pkgver=0.2.1
+pkgdesc="Demangle Rust symbol names"
+arch=('x86_64')
+url="https://github.com/luser/rustfilt"
+license=('Apache')
+depends=('gcc-libs')
+makedepends=('rust')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('f09bb822c8b22c4c89bf63cc64f8f85a053e1850a70cad4b7308e00871527496')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --frozen
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --frozen
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+}