summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f197500e2cd8..0137e70a593c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Pedro Simões pedrofchsimoes@gmail.com
pkgname='rusty-monitor-git'
_pkgname='rusty-monitor'
-pkgver=r19.fefc628
+pkgver=r24.b86860a
pkgrel=1
pkgdesc="This is a simple system monitor built with Rust and GTK4"
arch=('x86_64')
url="https://github.com/hubblexplorer/rusty-monitor"
license=('GPL3')
-depends=('base' 'gtk4' 'glib2')
+depends=('base' 'gtk4' 'glib2' 'pciutils')
makedepends=('git' 'cargo')
source=("$pkgname::git+https://github.com/hubblexplorer/rusty-monitor.git")
md5sums=('SKIP')
@@ -28,4 +28,6 @@ build() {
package() {
cd "$srcdir/$pkgname"
install -Dm 755 "target/release/rusty-monitor" -t "$pkgdir/usr/bin/"
+ install -Dm 655 "src/assets/icons/rusty-monitor.svg" -t "$pkgdir/usr/share/icons/"
+ install -Dm 777 "rusty-monitor.desktop" -t "$pkgdir/usr/share/applications/"
}