summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c87f13d7a57..09cf7182c426 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,15 @@
_pkgname="s2argv-execs"
pkgname="$_pkgname-git"
-pkgver=r37.aa3c3d6
-pkgrel=2
+pkgver=r38.2f3f79c
+pkgrel=1
pkgdesc="s2argv converts a command string into an argv array for execv*, execs is like execv taking a string instead of an argv"
arch=('any')
-url="https://github.com/rd235/$_pkgname"
+url="https://github.com/virtualsquare/$_pkgname"
license=('LGPL')
+groups=('virtualsquare')
depends=('glibc')
-makedepends=('git')
+makedepends=('git' 'cmake')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+$url.git")
@@ -24,12 +25,13 @@ pkgver() {
build() {
cd "$_pkgname"
- autoreconf -if
- ./configure --prefix="/usr"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd "$_pkgname"
+ cd "$_pkgname"/build
make DESTDIR="$pkgdir/" install
}