summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af2e87f1e2a5..e24cf26d3f0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Thorsten Mueller <info@thorko.de>
-# Contributor:
+# Contributor:
pkgname=samhain-server
-pkgver=4.3.2
+pkgver=4.4.1
pkgrel=1
pkgdesc="file integrity / intrusion detection system"
arch=(x86_64 armv7h)
@@ -10,19 +10,23 @@ url="http://www.la-samhna.de/"
license=('GPL')
install=samhain.install
source=("http://www.la-samhna.de/samhain/samhain-current.tar.gz"
- "yule.service")
-sha256sums=('0582864ef56ab796031e8e611ed66c48adeb3a30ec34e1a8d0088572442035fc'
- 'f8c579fd60b1004272351f257374615d99adab43249b746f557abf0f91cd4c90')
-validpgpkeys=('EF6CEF54701A0AFDB86AF4C31AAD26C80F571F6C')
+ "yule.service"
+ "patch0")
+sha256sums=('a15516f6809b1daf812b39fb5aa6be3fac1a51b5efca53568759fdf54572a2e9'
+ 'f8c579fd60b1004272351f257374615d99adab43249b746f557abf0f91cd4c90'
+ '48d93ceea68b4549aa2fb26488345a639b4c700da6af649d2b320bde4a268437')
+validpgpkeys=('EF6CEF54701A0AFDB86AF4C31AAD26C80F571F6C')
+
build() {
echo "Note: If the GPG verification fails, import the Samhain GPG key: http://www.la-samhna.de/samhain/s_rkey.html"
gpg --verify samhain-${pkgver}.tar.gz.asc samhain-${pkgver}.tar.gz
tar -zxvf samhain-${pkgver}.tar.gz
cd "samhain-${pkgver}"
+ patch -p0 < ../patch0
# see samhain documentation, lots of other options available. e.g. use --enable-network=server to run in server mode.
#./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin
- ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin --enable-network=server
+ ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --sbindir=/usr/bin --enable-network=server --disable-asm
make
}
@@ -30,7 +34,6 @@ package() {
cd "samhain-${pkgver}"
make DESTDIR="$pkgdir/" install
chmod 755 ${pkgdir}/usr/bin/yule
- chmod 755 ${pkgdir}/usr/bin/yuleadmin.pl
chmod 755 ${pkgdir}/usr/bin/yule_setpwd
chmod 755 ${pkgdir}/usr/bin/yulectl
chmod 644 ${pkgdir}/etc/yulerc