summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82f69218b605
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
+pkgname=scap-workbench
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Security Content Automation Protocol GUI"
+arch=('x86_64')
+url='https://www.open-scap.org/tools/scap-workbench/'
+license=('BSD')
+depends=('asciidoc' 'openscap' 'openssh' 'qt5-base' 'qt5-xmlpatterns' 'scap-security-guide')
+source=("https://github.com/OpenSCAP/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2")
+sha256sums=('d1508461d0e841cf8b8063877904b8b4bb0dae26c6c5370e47e0255157fdb84f')
+
+build() {
+ cd "$pkgname-$pkgver"
+ mkdir -p build
+ cd build
+ cmake \
+ --install-prefix=/usr \
+ -DCMAKE_CXX_FLAGS='-std=c++11 -Wno-error=c++20-compat -Wno-error=range-loop-construct -Wno-error=deprecated-declarations' \
+ ..
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}