summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 3 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6ae3146d54a..ae6769c811a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=sdl
pkgname=$_pkgname-hg
-pkgver=1.2.15.r11979.d684a767e240
+pkgver=1.2.15.r12076.3e05d58dc84f
pkgrel=1
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard"
arch=('i686' 'x86_64')
@@ -25,14 +25,8 @@ pkgver() {
cd "SDL/"
printf "%s.r%s.%s" \
"$(hg log -r . -T "{latesttag}" | sed 's/^release-//')" \
- "$(hg identify -n | sed 's/+//')" \
- "$(hg identify -i | sed 's/+//')"
-}
-
-prepare() {
- cd "SDL/"
- # https://bugzilla.libsdl.org/show_bug.cgi?id=1430
- hg backout --no-commit 5620:ad4ed9f0336f
+ "$(hg identify -n)" \
+ "$(hg identify -i)"
}
build() {