summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3a739bcd416..e17346210b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
pkgname=seiscomp3
_screlease=jakarta
pkgver=2017.334.05
-pkgrel=1
+pkgrel=2
pkgdesc="A seismological software for data acquisition, processing, distribution and interactive analysis."
arch=('x86_64')
url="https://www.seiscomp3.org/"
license=('custom')
-depends=('boost-libs' 'libxml2' 'mariadb' 'ncurses' 'openssl' 'python2' 'python2-m2crypto' 'qt4')
+depends=('boost-libs' 'libtirpc' 'libxml2' 'mariadb' 'ncurses' 'openssl' 'python2' 'python2-m2crypto' 'qt4')
makedepends=('boost' 'cmake' 'libmariadbclient' 'postgresql-libs' 'python2-sphinx')
optdepends=('postgresql: for using PostgreSQL database')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/SeisComP3/${pkgname}/archive/release/${_screlease}/${pkgver}.tar.gz"
@@ -29,6 +30,9 @@ build() {
cd "${pkgname}-release-${_screlease}-${pkgver}/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX='/opt/seiscomp3' \
+ -DCMAKE_CXX_FLAGS='-I/usr/include/tirpc' \
+ -DCMAKE_SHARED_LINKER_FLAGS='-ltirpc' \
+ -DCMAKE_EXE_LINKER_FLAGS='-ltirpc -lpthread' \
-DPYTHON_EXECUTABLE='/usr/bin/python2' \
-DSC_DOC_GENERATE='ON'
make