summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd25bf2b58e3..3094345e2a77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,20 @@
#Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
pkgname='sfxr-qt'
-pkgver=1.5.0
-pkgrel=2
+pkgver=1.5.1
+pkgrel=1
pkgdesc='Qt port of SFXR, a sound effect generator, to generate retro-gaming like sound effects'
arch=('x86_64')
url='https://github.com/agateau/sfxr-qt'
license=('MIT')
-depends=('hicolor-icon-theme' 'python-jinja' 'python-pyaml' 'qt5-base' 'qt5-declarative' 'sdl' 'catch2-v2')
+depends=('hicolor-icon-theme' 'python-jinja' 'python-pyaml' 'qt5-base' 'qt5-declarative' 'qt5-quickcontrols2' 'sdl' 'catch2')
makedepends=('cmake' 'extra-cmake-modules' 'git')
source=("git+${url}.git#tag=${pkgver}"
- "git+${url%/*}/qpropgen.git"
- "https://patch-diff.githubusercontent.com/raw/agateau/sfxr-qt/pull/14.patch"
- "https://patch-diff.githubusercontent.com/raw/agateau/sfxr-qt/pull/16.patch")
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+ "git+${url%/*}/qpropgen.git")
+sha256sums=('SKIP' 'SKIP')
prepare() {
cd "${pkgname}"
- patch --forward --strip=1 --input="${srcdir}/14.patch"
- patch --forward --strip=1 --input="${srcdir}/16.patch"
# Submodule list: https://github.com/agateau/sfxr-qt/raw/master/.gitmodules
git submodule init