summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14f2c94904e2..62512458aba6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=signal-desktop-bin
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc='Private messaging from your desktop'
arch=('x86_64')
url='https://github.com/signalapp/Signal-Desktop'
@@ -21,6 +21,9 @@ package() {
# extract package data
tar xf data.tar.xz -C "${pkgdir}"
+ # fix permissions in 1.9.0 (Some directories have now 775; changing them back to 755)
+ find "${pkgdir}" -type d -not -perm 755 -exec chmod 755 {} \;
+
# install alias in /usr/bin
mkdir "${pkgdir}/usr/bin"
install -D -m755 signal-desktop "${pkgdir}/usr/bin/signal-desktop"