summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22d0b360c7bd..aa10291257b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,33 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
pkgname=slackdump
-pkgver=2.5.7
+pkgver=2.5.8
pkgrel=1
pkgdesc='Save your private and public slack messages, threads, files, and users locally'
-arch=('x86_64')
-url="https://github.com/rusq/slackdump"
-license=('GPL-3.0-only')
-depends=('glibc')
-makedepends=('go')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/rusq/${pkgname}/archive/refs/tags/v${pkgver//_/-}.tar.gz")
-b2sums=('d7f068d6241016d9543a23d2deb9a6bea671c4f252811bebf5dbcd750a7d3011f82076df1f3fbf9c89b2a994f07eed413c67d5fb7804213fa3d2b43e971eb9c5')
+arch=(x86_64)
+url=https://github.com/rusq/slackdump
+license=(GPL-3.0-only)
+depends=(glibc)
+makedepends=(go)
+source=($pkgname-$pkgver.tar.gz::https://github.com/rusq/$pkgname/archive/refs/tags/v${pkgver//_/-}.tar.gz)
+b2sums=('e244a37550915cbe2ba9724eef83c86bff11d58999611fd86dd01c0e97b5e02eddf77659311e10ec1d3d5063eabb28df772df3f70682328895fa8253a478c17f')
build() {
- cd "${pkgname}-${pkgver//_/-}"
+ cd $pkgname-${pkgver//_/-}
mkdir -p build
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export CGO_LDFLAGS="$LDFLAGS"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -o build ./cmd/...
}
check() {
- cd "${pkgname}-${pkgver//_/-}"
+ cd $pkgname-${pkgver//_/-}
go test ./...
}
package() {
- cd "${pkgname}-${pkgver//_/-}"
- install -Dm755 build/${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+ cd $pkgname-${pkgver//_/-}
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
}