summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 26 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7f886a651f4..34391672c07e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
# Maintainer: Lucki <https://aur.archlinux.org/account/Lucki/>
# Contributor: leper <blubblub@mail.ru>
+# shellcheck disable=SC2034,2154,2148
pkgname=smokinguns-git
_pkgname=${pkgname%-git}
pkgver=1.1.r859.gf5d9ecf2
-pkgrel=7
+pkgrel=8
pkgdesc='A semi-realistic simulation of the old west great atmosphere built on id Tech 3.'
url="https://www.smokin-guns.org"
arch=('i686' 'x86_64')
license=('GPL2')
changelog=.CHANGELOG
-depends=('sdl' 'speex' 'hicolor-icon-theme' 'freetype2' 'libgl' 'libjpeg-turbo')
-makedepends=('git' 'openal' 'glu')
+depends=('freetype2' 'hicolor-icon-theme' 'libgl' 'libjpeg-turbo' 'libogg' 'sdl' 'speex' 'zlib')
+makedepends=('git' 'glu' 'openal')
conflicts=('smokinguns-bin' 'smokinguns' 'smokinguns-data')
provides=('smokinguns-data' 'smokinguns')
-source=("$_pkgname::git+https://github.com/smokin-guns/SmokinGuns.git"
- "$_pkgname-data.zip::https://www.smokin-guns.org/downloads/Smokin_Guns_1.1.zip"
- "$_pkgname.desktop")
+source=("$pkgname::git+https://github.com/smokin-guns/SmokinGuns.git"
+ "$pkgname.data.zip::https://www.smokin-guns.org/downloads/Smokin_Guns_1.1.zip"
+ "$pkgname.desktop"
+ "$pkgname-#11-build-fail.patch")
sha512sums=('SKIP'
'51954ce00cccd9eb95a10491f0fcdea2d024058da11cbda7ee56c6369e8bc101d89ed95549cf4255393c3e1bec4585be12937e7ed7b20ff4cc0ce96685a5ce72'
- '37aefb4a9e811644af09bbbfdb35d6a2572bc70b6fe8ff0078330d1070e73ebcd18f2e656156f1e3d92b2ec7f6fdffe63b2c66018b449d8b5aa6402b3eb24d7d')
+ '37aefb4a9e811644af09bbbfdb35d6a2572bc70b6fe8ff0078330d1070e73ebcd18f2e656156f1e3d92b2ec7f6fdffe63b2c66018b449d8b5aa6402b3eb24d7d'
+ '4ad6e8c1775ccce791810349febfbcc9235bb4cc1310d0b5eb61ea522558c32457e192ab1b9860215d72441c708638cfa845af56e4749a0bfeecaa5bf120d051')
-pkgver()
-{
- cd "$srcdir/$_pkgname" || exit
+pkgver() {
+ cd "$pkgname" || exit
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare()
-{
- cd "$srcdir/$_pkgname" || exit
-
+prepare() {
+ cd "$pkgname" || exit
{
# Set basedir
echo "DEFAULT_BASEDIR = /usr/share/$_pkgname"
@@ -46,23 +46,28 @@ prepare()
echo "USE_LOCAL_HEADERS=0"
} >> "Makefile.local"
+
+ # https://github.com/smokin-guns/SmokinGuns/issues/11
+ patch --forward --strip=1 --input="$srcdir/$pkgname-#11-build-fail.patch"
}
-build()
-{
- cd "$srcdir/$_pkgname" || exit
+build() {
+ cd "$pkgname" || exit
make
}
-package()
-{
- cd "$srcdir/Smokin' Guns 1.1" || exit
+package() {
+ install -Dm 644 "$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$_pkgname.desktop"
+
+ cd "Smokin' Guns 1.1" || exit
+
install -d "$pkgdir/usr/share/$_pkgname/baseq3"
install -m 644 baseq3/* "$pkgdir/usr/share/$_pkgname/baseq3"
install -d "$pkgdir/usr/share/$_pkgname/$_pkgname"
install -m 644 "$_pkgname"/* "$pkgdir/usr/share/$_pkgname/$_pkgname"
- cd "$srcdir/$_pkgname" || exit
+ cd "$srcdir/$pkgname" || exit
SUFFIX=${CARCH//i686/i386}
install -Dm 755 "build/release-linux-$SUFFIX/$_pkgname.$SUFFIX" \
@@ -77,10 +82,6 @@ package()
install -Dm 644 "build/release-linux-$SUFFIX/renderer_opengl2_$SUFFIX.so" \
"$pkgdir/usr/share/$_pkgname"
- install -Dm 644 "$srcdir/$_pkgname.desktop" \
- "$pkgdir/usr/share/applications/$_pkgname.desktop"
-
install -Dm 644 "misc/$_pkgname.png" \
"$pkgdir/usr/share/icons/hicolor/256x256/apps/$_pkgname.png"
}
-