summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 18 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 750951c80646..0c1b92b07ce6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=snap-git
_pkgname=Snap
-#pkgver=2.4
-pkgver=r1433.2d92ca1
+#pkgver=4.1
+pkgver=r1857.86ac647
pkgrel=1
pkgdesc='Stanford Network Analysis Platform (SNAP) is a general purpose, high performance system for analysis and manipulation of large networks.'
arch=( 'i686' 'x86_64' 'armv6' 'armv6h' 'arm7h' )
-url='http://tulip.labri.fr/'
+url='http://snap.stanford.edu/snap/'
license=('GPL')
depends=(
'gnuplot'
@@ -17,13 +17,18 @@ makedepends=(
'make'
)
source=(
+ #"${pkgname}::git+https://github.com/yhfudev/snap.git"
#"http://snap.stanford.edu/releases/${_pkgname}-${pkgver}.zip"
- #"${pkgname}::git+https://github.com/snap-stanford/snap.git"
- "${pkgname}::git+https://github.com/yhfudev/snap.git"
+ "${pkgname}::git+https://github.com/snap-stanford/snap.git"
+ snap-autoconf.patch
+ snap-compile-error.patch
)
#sha1sums=('8eefd6f8ce3c2fe9bea9a8c47920f1cba7fc667b')
#md5sums=('5ab35fa4ad262399d5234ec7a04d457d')
-md5sums=(SKIP)
+md5sums=(SKIP
+255a4d6e3694015f068c3e708bd9084f # snap-autoconf.patch
+35fc0b82f4a4eab9c955f74ef75e315e # snap-compile-error.patch
+)
pkgver_git() {
cd "${srcdir}/${pkgname}"
@@ -47,7 +52,12 @@ pkgver() {
prepare()
{
cd "${srcdir}/${pkgname}"
- #cd "${srcdir}/${pkgname}-${pkgver}"
+ #cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ patch -p1 -i ${srcdir}/snap-autoconf.patch
+ chmod 755 ./autogen.sh
+ chmod 755 ./autoclean.sh
+ patch -p1 -i ${srcdir}/snap-compile-error.patch
}
build()
@@ -73,4 +83,5 @@ package()
#cd "${srcdir}/${_pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
+ rmdir "${pkgdir}/usr/include/libsnap/blank/"
}