summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7d1df4cd011..8adcffb72039 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=snap7
pkgver=1.4.2
-pkgrel=2
+pkgrel=3
pkgdesc="Step7 Open Source Ethernet Communication Suite"
url="http://snap7.sourceforge.net/"
license=("LGPL3")
@@ -26,15 +26,12 @@ case "$CARCH" in
esac
build() {
- cd "${srcdir}/${pkgname}-full-${pkgver}/build/unix/"
- make -f ${_pkgarch}_linux.mk all
+ cd "${srcdir}/${pkgname}-full-${pkgver}/build/unix/"
+ make -f ${_pkgarch}_linux.mk all
}
package() {
- cd "${srcdir}/${pkgname}-full-${pkgver}/build/"
+ cd "${srcdir}/${pkgname}-full-${pkgver}/build/"
- install -dm755 "${pkgdir}/usr/lib"
- install -dm755 "${pkgdir}/usr/include"
-
- cp -a bin/${_pkgarch}-linux/libsnap7.so "${pkgdir}/usr/lib/"
+ install -D -m755 "bin/${_pkgarch}-linux/libsnap7.so" "${pkgdir}/usr/lib/libsnap7.so"
}