summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 16 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c86a70533caa..b28cf50863d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Stefan Göbel < snot ʇɐ subtype ˙ de >
pkgname='snot'
+_reltag='0.3-pie'
pkgver='0.3'
pkgrel='1'
pkgdesc='Basic Btrfs snapshot tool.'
@@ -8,8 +9,8 @@ arch=('x86_64' 'i686')
url='https://gitlab.com/goeb/snot'
license=('GPL3')
depends=('btrfs-progs')
-makedepends=('git' 'go-pie' 'python-docutils')
-source=("$pkgname::git+https://gitlab.com/goeb/$pkgname.git#tag=$pkgver")
+makedepends=('git' 'go' 'python-docutils')
+source=("$pkgname::git+https://gitlab.com/goeb/$pkgname.git#tag=$_reltag")
sha256sums=('SKIP')
backup=(
'etc/pacman.d/hooks/snot.hook'
@@ -26,6 +27,11 @@ backup=(
build() {
export GOCACHE="$srcdir/.gocache"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="$LDFLAGS"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=vendor -modcacherw"
cd "$pkgname"
@@ -34,6 +40,14 @@ build() {
}
+check() {
+
+ cd "$pkgname"
+
+ make testall
+
+}
+
package() {
cd "$pkgname"