summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 3 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dfdc4a95705c..482cd4f9ce05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Contributor: Alexandre Jesus <adbjesus@gmail.com>
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-pkgbase=soccer-cli-git
-pkgname=('python2-soccer-cli-git' 'python-soccer-cli-git')
+pkgname=soccer-cli-git
epoch=1
-pkgver=20190116_r298.472e9f4
-pkgrel=3
+pkgver=20211129_r306.04932b6
+pkgrel=1
pkgdesc="Soccer for Hackers - a CLI for all the football scores."
arch=('any')
url="https://github.com/architv/soccer-cli"
@@ -13,7 +12,6 @@ license=('MIT')
makedepends=('git' 'python' 'python2')
source=('git+https://github.com/architv/soccer-cli.git')
md5sums=('SKIP')
-install="${pkgbase}.install"
pkgver() {
cd ${pkgbase%-git}
@@ -27,21 +25,9 @@ prepare() {
sed -i -e 's/requests==2/requests>=2/' setup.py
cd ..
- cp -r ${pkgbase%-git} ${pkgbase%-git}2
cp -r ${pkgbase%-git} ${pkgbase%-git}3
}
-package_python2-soccer-cli-git() {
- depends=('python2-click' 'python2-requests')
- provides=('python2-soccer-cli')
- cd ${pkgbase%-git}2
-
- install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
-
- python2 setup.py install --root="$pkgdir/" --optimize=1
- mv "$pkgdir"/usr/bin/soccer "$pkgdir"/usr/bin/soccer2
-}
-
package_python-soccer-cli-git() {
depends=('python-click' 'python-requests')
provides=('python-soccer-cli')