summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 639a91d23803..046354b8b130 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-# Maintainer: Tun Win Naing <twnaing(at)outlook(dot)com>
-# Maintainer: Jonathan Liu <net147@gmail.com>
+# Maintainer: qwjyh <urataw421 at gmail dot com>
+# Contributor: Tun Win Naing <twnaing(at)outlook(dot)com>
+# Contributor: Jonathan Liu <net147@gmail.com>
+
pkgname=softethervpn
-pkgver=v4.38_9760
+pkgver=v4.42_9798
pkgrel=2
pkgdesc="Multi-protocol VPN Program from University of Tsukuba"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
url="https://www.softether.org/"
license=('Apache')
depends=('bash' 'openssl' 'zlib')
-source=("https://www.softether-download.com/files/softether/${pkgver//_/-}-rtm-2021.08.17-tree/Source_Code/softether-src-${pkgver//_/-}-rtm.tar.gz"
+source=("https://www.softether-download.com/files/softether/${pkgver//_/-}-rtm-2023.06.30-tree/Source_Code/softether-src-${pkgver//_/-}-rtm.tar.gz"
'aarch64.patch'
+ 'linux_32bit.patch'
+ 'linux_64bit.patch'
'softethervpn-bridge.service'
'softethervpn-client.service'
'softethervpn-server.service')
-md5sums=('8df486ba22fdb14212c453c7211587a8'
+md5sums=('bd70e9ae9a19c3f227c26d731503cc7f'
'8b92f69f9d8d852a3739d0e48bad0454'
+ '576277be87dd458c8d889d24a0072abe'
+ '1b3d536da4b9fa9a79f113089c13252e'
'1d54c0065ae8947bd8455b9e2050c1af'
'a1134fea991e6e00dc4910b1be16dc73'
'b54b4f68d56555ddfffc50c2c399624f')
@@ -24,12 +30,16 @@ build(){
patch -Np1 -i "${srcdir}/aarch64.patch"
if [ "${CARCH}" == "i686" ]; then
+ patch src/makefiles/linux_32bit.mak "${srcdir}/linux_32bit.patch"
cp src/makefiles/linux_32bit.mak Makefile
elif [ "${CARCH}" == "x86_64" ]; then
+ patch src/makefiles/linux_64bit.mak "${srcdir}/linux_64bit.patch"
cp src/makefiles/linux_64bit.mak Makefile
elif [ "${CARCH}" == "aarch64" ]; then
+ patch src/makefiles/linux_64bit.mak "${srcdir}/linux_64bit.patch"
cp src/makefiles/linux_64bit.mak Makefile
elif [ "${CARCH}" == "armv7h" ]; then
+ patch src/makefiles/linux_32bit.mak "${srcdir}/linux_32bit.patch"
cp src/makefiles/linux_32bit.mak Makefile
fi