summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 528d509dfe4f..fb2591a946b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=sogo
pkgdesc="groupware server built around OpenGroupware.org (OGo) and the SOPE application server"
pkgver=4.0.2
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="http://www.sogo.nu/"
license=('GPL')
@@ -32,24 +32,25 @@ backup=('etc/sogo/sogo.conf'
'etc/httpd/conf/extra/SOGo.conf'
'etc/conf.d/sogo')
source=("http://www.sogo.nu/files/downloads/SOGo/Sources/SOGo-${pkgver}.tar.gz"
- "sogo_configure.patch"
"sogo.service"
- "sogo.confd")
+ "sogo.confd"
+ "sogo_configure.patch"
+ "ssl_load_error.patch")
sha256sums=('35ef20216ff1758a593bed69d8e8e25d23e982a970bf23a3bb2f856f2e5d2f9f'
- 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
'0720b9ad35a05d86d794c7adbf18277ecde57ed147e96f6105acca93f19d3b8c'
- '8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7')
+ '8ee0d1ad77e998ea801053fce175d8c4a1c55dcc5ee1ff78f0a8e3797187a6a7'
+ 'e64ea4aa0ddf29785de8d786ab7ab09f940bfe316b6f1deeb8d04d9d16d35db1'
+ '55934b0763d809b30ac8b597f5c8be32c9226040c5c8d9eff2bb9cc004072c17')
prepare() {
cd "$srcdir/SOGo-${pkgver}"
patch configure ../sogo_configure.patch
+ patch -Np1 -i ../ssl_load_error.patch
}
build() {
cd "$srcdir/SOGo-${pkgver}"
./configure --prefix=$(gnustep-config --variable=GNUSTEP_SYSTEM_ROOT) --disable-debug
- # fix ssl error message, this should be harmless
- sed '/SSL_load_error_strings/d' -i UI/MailPartViewers/UIxMailPartSignedViewer.m
make
}