summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 70f0843b78b8..c0aee3ecbfab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
_gitname=spicetify-cli
pkgname="${_gitname}-git"
-pkgver=2.6.1.r2.gc84c381
-pkgrel=2
+pkgver=2.16.1.r1.gd5cc68f
+pkgrel=1
pkgdesc='Command-line tool to customize Spotify client - Git master branch'
arch=('x86_64' 'i686')
-url="https://github.com/khanhas/${_gitname}"
-license=('GPL')
+url="https://github.com/spicetify/${_gitname}"
+license=('LGPL2.1')
makedepends=('git' 'go')
source=("git+${url}.git")
sha256sums=('SKIP')
@@ -20,17 +20,21 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd "$srcdir/${_gitname}"
- export GOPATH="$srcdir"
- go build -o spicetify
+ echo "#!/bin/sh
+/usr/share/${_gitname}/spicetify \"\$@\"" > ./shortcut
}
-check() {
+build() {
cd "$srcdir/${_gitname}"
- ./spicetify -v
+ export GOPATH="$srcdir"
+ go build -o spicetify
+
+ # Clean up deps
+ go clean -modcache
}
package() {
@@ -39,12 +43,6 @@ package() {
install -Dm755 ./spicetify "$pkgdir"/usr/share/${_gitname}/spicetify
cp -r ./Themes ./css-map.json ./Extensions ./CustomApps ./jsHelper ./globals.d.ts -t "$pkgdir"/usr/share/${_gitname}
- rm -f ./shortcut
- echo "#!/bin/sh
-/usr/share/${_gitname}/spicetify \"\$@\"" >> ./shortcut
install -Dm755 ./shortcut "$pkgdir"/usr/bin/spicetify
-
- # Clean up deps
- go clean -modcache
}
# vim:set ts=2 sw=2 et: