summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d694caa5710..00f4abbcbc0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Angelo Theodorou <encelo@gmail.com>
pkgname=spookyghost-git
-pkgver=r71.d3660bf
+pkgver=r75.837135d
pkgrel=1
pkgdesc="A procedural sprite animation tool made with the nCine"
arch=('i686' 'x86_64')
@@ -12,8 +12,18 @@ makedepends=('git' 'cmake')
conflicts=('spookyghost')
provides=('spookyghost')
options=(!strip)
-source=('git+https://github.com/SpookyGhost2D/SpookyGhost')
-md5sums=('SKIP')
+source=(
+ 'git+https://github.com/SpookyGhost2D/SpookyGhost'
+ 'git+https://github.com/nCine/nCine'
+ 'git+https://github.com/nCine/nCine-data'
+ 'git+https://github.com/SpookyGhost2D/SpookyGhost-data'
+)
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd "$srcdir/SpookyGhost"
@@ -23,12 +33,6 @@ pkgver() {
)
}
-prepare() {
- git clone https://github.com/nCine/nCine || git -C nCine pull
- git clone https://github.com/nCine/nCine-data || git -C nCine-data pull
- git clone https://github.com/SpookyGhost2D/SpookyGhost-data || git -C SpookyGhost-data pull
-}
-
build() {
cmake -S nCine -B nCine-build\
-DCMAKE_BUILD_TYPE=Release\