summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35351db9d68a..ebbdf40f6969 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=squashfs-tools-git
_pkgbasename=squashfs-tools
-pkgver=1808.6e242dc
+pkgver=1935.c570c61
pkgrel=1
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="https://github.com/plougher/squashfs-tools"
@@ -16,10 +16,8 @@ arch=('x86_64')
depends=('zlib' 'lzo' 'xz' 'lz4' 'zstd')
conflicts=('squashfs-tools')
provides=('squashfs-tools')
-source=("squashfs-tools::git+https://github.com/plougher/squashfs-tools.git"
- "glibc-compat.patch::https://patch-diff.githubusercontent.com/raw/plougher/squashfs-tools/pull/52.patch")
-sha512sums=('SKIP'
- '5c47a63e711ccde0a692c6be89c9d0c3590461458087f114decd404616b7b75d25f05d5e216fd2ffd95e5404f7a27a4837701341337d0faae22d5fe6a1b97da8')
+source=("squashfs-tools::git+https://github.com/plougher/squashfs-tools.git")
+sha512sums=('SKIP')
pkgver() {
cd ${_pkgbasename}
@@ -28,12 +26,11 @@ pkgver() {
prepare() {
cd "${srcdir}"/${_pkgbasename}
- patch -Np1 -i ../glibc-compat.patch
}
build() {
cd "$srcdir"/${_pkgbasename}/${_pkgbasename}
- CFLAGS="$CFLAGS -O2" make XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1 LZ4_SUPPORT=1 ZSTD_SUPPORT=1
+ CFLAGS="$CFLAGS -O2" make XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1 LZ4_SUPPORT=1 ZSTD_SUPPORT=1 GZIP_SUPPORT=1 XATTR_SUPPORT=1
}
package() {