summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc5172530876..efd6b1625d00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-_pkgname=stagit-gopher
-pkgname=${_pkgname}-git
-pkgver=0.9.3.r0.gde86bac
+_pkgname='stagit-gopher'
+pkgname="${_pkgname}-git"
+pkgver=0.9.4.r0.g218c16a
pkgrel=1
pkgdesc='Static gopher site generator for git version control'
-arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+arch=('x86_64')
url='https://codemadness.org/stagit-gopher.html'
license=('MIT')
depends=('libgit2')
makedepends=('git')
-optdepends=('geomyidae: small c-based gopherd')
+optdepends=('geomyidae: small c-based gopherd'
+ 'git: scripting functionality')
provides=("${_pkgname}")
+conflicts=("${_pkgname}")
source=("git://git.codemadness.org/${_pkgname}")
sha256sums=('SKIP')
@@ -24,8 +26,8 @@ build() {
}
package() {
- make DESTDIR="${pkgdir}" PREFIX="/usr" MANPREFIX="/usr/share/man" -C "${_pkgname}" install
- install -Dm644 "${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ make DESTDIR="${pkgdir}" PREFIX='/usr' MANPREFIX='/usr/share/man' -C "${_pkgname}" install
+ install -Dvm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${_pkgname}"
}
-# vim: ts=2 sw=2 et: \ No newline at end of file
+# vim: ts=2 sw=2 et: