summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 7 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 875c08d57800..95eec8a3f5ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=stm32cubemonitor
_pkgname=STM32CubeMon
-_pkg_file_name=en.stm32cubemon-lin-v-1-7-0.zip
-pkgver=1.7.0
+_pkg_file_name=en.stm32cubemon-lin-v-1-8-0.zip
+pkgver=1.8.0
pkgrel=1
pkgdesc="Graphical software for helping debug and diagnose STM32 applications while they are running by reading and displaying their variables in real-time"
arch=('x86_64')
@@ -24,8 +24,9 @@ _useragent_escaped="${_curl_useragent// /\\ }"
_curl_req_url="https://www.st.com/content/st_com_cx/en/products/development-tools/software-development-tools/stm32-software-development-tools/stm32-performance-and-debuggers/stm32cubemonitor/_jcr_content/get-software/get-software-table-body.nocache.html/st-site-cx/components/containers/product/get-software-table-body.html"
_curl_req="$(curl -s --compressed -H "$_curl_useragent" "$_curl_req_url")"
-_curl_req="$(grep -m 1 "${_pkg_file_name}" <<< "$_curl_req")"
-_download_path="https://www.st.com""$(awk -F'"' '{print $4}' <<< "$_curl_req")"
+_pkg_url="$(grep -m 1 "${_pkg_file_name}" <<< "$_curl_req")"
+_pkg_url="$(awk -F'"' '{print $4}' <<< "$_pkg_url")"
+_download_path="https://www.st.com""$_pkg_url"
DLAGENTS=("https::/usr/bin/curl \
-gqb '' --retry 3 --retry-delay 3 \
@@ -34,18 +35,8 @@ DLAGENTS=("https::/usr/bin/curl \
source=("${_pkg_file_name}"::"$_download_path")
-sha256sums=('68f6fec8214fd21c6e2dbc872fc1f8d977f19d9c1bab1e4ff6b31e8855a3cc38')
+sha256sums=('6964b9a02ce0bf6c142246c8c40659a032e2df76652e73e48e77f770666506bb')
-# Extracted Files from ${_pkg_file_name}
-# ├── driver
-# │ └── st-stlink-udev-rules-1.0.2-3-linux-all.deb
-# ├── licenses
-# │ ├── Gnu Arm Embedded Toolchain EULA.txt
-# │ ├── LICENSES.chromium.html
-# │ ├── licenses_list_STM32CubeMonitor.txt
-# │ └── SLA0048 rev4.pdf
-# ├── snapshot_embedded_SW.zip
-# └── stm32cubemonitor_${pkgver}_amd64.deb
prepare() {
install -dm755 build
@@ -65,7 +56,7 @@ package() {
ln -fs /opt/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
# license
- for _license in ${srcdir}//licenses/*
+ for _license in ${srcdir}/licenses/*
do
install -Dm644 "${_license}" -t ${pkgdir}/usr/share/licenses/${pkgname}/
done