summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6c1d5bcdf30..774a41f60dc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Rafal Bolanowski <robin92pl@gmail.com>
pkgname=subconvert
pkgver=2.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="Movie subtitles converter"
arch=('any')
url="https://github.com/mgoral/subconvert/"
@@ -9,8 +9,19 @@ license=('GPL3')
depends=('python>=3.2' 'python-pyqt5>=5.5' 'python-chardet>=2.3' 'mplayer' 'gettext>=0.19')
makedepends=('intltool')
checkdepends=('python-nose')
-source=("https://github.com/mgoral/$pkgname/archive/$pkgver.tar.gz")
-sha1sums=('c583da37dc9b7ec0807d2e5058c2db8d4abe5e62')
+source=(
+ "https://github.com/mgoral/$pkgname/archive/$pkgver.tar.gz"
+ "pyqt515-mainwindow-slot-signature.patch"
+)
+sha1sums=(
+ 'c583da37dc9b7ec0807d2e5058c2db8d4abe5e62'
+ '13c93e585d0677e2e7c5e284e8d2fda351ea507c'
+)
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/pyqt515-mainwindow-slot-signature.patch"
+}
build() {
cd "$pkgname-$pkgver"