summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3fee5562a43a..240f0f14c6df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-_pkgname=swifty
-pkgname="${_pkgname}-appimage"
+pkgname="swifty-appimage"
pkgver=0.6.13
-pkgrel=2
+pkgrel=3
pkgdesc="Free Offline-first Password Manager for MacOS, Windows and Linux."
arch=("x86_64")
url="https://getswifty.pro/"
_githuburl="https://github.com/swiftyapp/swifty"
license=('GPL3')
-depends=(hicolor-icon-theme zlib glibc)
-conflit=("${_pkgname}")
-provides=("${_pkgname}")
+depends=('hicolor-icon-theme' 'zlib' 'glibc')
+conflit=("${pkgname%-appimage}")
+provides=("${pkgname%-appimage}")
options=(!strip)
-source=("${_pkgname}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/Swifty-${pkgver}.AppImage")
+source=("${pkgname%-appimage}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}/Swifty-${pkgver}.AppImage")
_install_path="/opt/appimages"
sha256sums=('1b68a992bd6ff11a8a21ca2cf1e873f239179d26829a55610ddbe86dc78be894')
prepare() {
- chmod a+x "${_pkgname}-${pkgver}.AppImage"
- "./${_pkgname}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed 's/Exec=AppRun/Exec=\/opt\/appimages\/swifty.AppImage/g' -i "${srcdir}/squashfs-root/${_pkgname}.desktop"
+ chmod a+x "${pkgname%-appimage}-${pkgver}.AppImage"
+ "./${pkgname%-appimage}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed 's|AppRun|/opt/appimages/swifty.AppImage|g' -i "${srcdir}/squashfs-root/${pkgname%-appimage}.desktop"
}
package() {
- install -Dm755 "${srcdir}/${_pkgname}-${pkgver}.AppImage" "${pkgdir}/${_install_path}/${_pkgname}.AppImage"
- install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${_pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
- install -Dm644 "${srcdir}/squashfs-root/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm755 "${srcdir}/${pkgname%-appimage}-${pkgver}.AppImage" "${pkgdir}/${_install_path}/${pkgname%-appimage}.AppImage"
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/0x0/apps/${pkgname%-appimage}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-appimage}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file