summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aac645529a94..584911edfd09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,25 @@
pkgname=swish-e
pkgver=2.4.7
pkgrel=1
-pkgdesc="Fast, flexible and free open source system for indexing collections of Web pages or other files."
+pkgdesc="Fast, flexible and free open source system for indexing collections of Web pages or other files"
arch=('i686' 'x86_64')
-url="http://www.swish-e.org"
+url="http://www.swish-e.org/"
license=('custom')
depends=('libxml2')
source=(http://www.swish-e.org/distribution/$pkgname-$pkgver.tar.gz)
-
md5sums=('736db7a65aed48bb3e2587c52833642d')
build() {
- cd ${srcdir}/$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
./configure --with-zlib --prefix=/usr --mandir=/usr/share/man --libexecdir=/usr/lib
- make || return 1
- make DESTDIR=${pkgdir} install
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
-#custom license
- install -D -m644 COPYING ${pkgdir}/usr/share/licenses/$pkgname/COPYING || return 1
+ make DESTDIR="${pkgdir}" install
+#license
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/$pkgname/COPYING
}