summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b4d7e0c99e1e..2e5d6ebab8d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
-# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=talktoniall
-pkgver=20121213
+pkgver=0.1
pkgrel=1
-pkgdesc='Talk to Niall'
+pkgdesc='Talk to Niall (a bit like a chatbot)'
arch=('x86_64' 'i686')
url='https://github.com/xyproto/talktoniall'
license=('GPL2')
-makedepends=('go' 'go-check' 'go-niall')
+makedepends=('go')
options=('!strip' '!emptydirs')
-source=("$pkgname.tgz::https://github.com/xyproto/$pkgname/archive/master.tar.gz")
-sha256sums=('aac754508c8592adc568ac65c605a78b2eb0c99e7434b2630240a2c3d164a3a8')
+source=("git://github.com/xyproto/talktoniall#tag=$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+
+ GOPATH="$srcdir" go get -d
+}
build() {
- cd "$srcdir/$pkgname-master"
+ cd "$pkgname"
- source /etc/profile.d/go.sh
- go build
+ GOPATH="$srcdir" go build
}
package() {
- cd "$srcdir/$pkgname-master"
+ cd "$pkgname"
- install -Dm755 "$pkgname-master" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
}
# vim:set ts=2 sw=2 et: