summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fa9e38e398b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: RickaPrincy <rckprincy@gmail.com>
+
+pkgname=tcolor
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="tcolor is a simple header file that provides you with options to print text in color within the terminal"
+arch=('any')
+url="https://github.com/RickaPrincy/TColor.hpp"
+license=('MIT')
+makedepends=("cmake")
+source=("TColor.tar.gz::https://github.com/RickaPrincy/TColor.hpp/releases/download/v$pkgver/TColor.tar.gz")
+sha256sums=("697e410c550ee639b28f15ad317fac13198e14a6559df644bffb23b1538d0bec")
+
+build() {
+ mkdir -p build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR=$pkgdir install
+} \ No newline at end of file