summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4e3e4bfda50..851ef86d92ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,23 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=teaftp
-pkgver=1.1.1
+pkgver=1.3.0
pkgrel=1
pkgdesc='Simple, read-only TFTP server'
arch=(x86_64)
url='https://github.com/xyproto/teaftp'
-license=(MIT)
+license=(BSD)
makedepends=(git go)
-source=("git+$url#tag=v$pkgver")
-md5sums=('SKIP')
+source=("git+$url#commit=27e21c589f95d823c60d0079d02246a3bfcb314f") # tag: v1.3.0
+b2sums=(SKIP)
build() {
- cd "$pkgname"
-
- export GO111MODULE=off
- go get -d
- go build -buildmode=pie
+ cd $pkgname
+ go build -buildmode=pie -ldflags="-s -w -extldflags \"${LDFLAGS}\"" -mod=vendor -trimpath -v
}
package() {
- cd "$pkgname"
-
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ cd $pkgname
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: ts=2 sw=2 et: