summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD83
1 files changed, 36 insertions, 47 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e76e53476d59..c808ce46e46a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,81 +5,69 @@
# https://github.com/mymedia2/tdesktop
pkgname=telegram-desktop-systemqt-emojione
-pkgver=1.0.29
+pkgver=1.1.15
pkgrel=1
-pkgdesc='Experimental build of Telegram Desktop (using system Qt, emojis replaced with those from EmojiOne.)'
+pkgdesc='Experimental build of Telegram Desktop (using system Qt, emojis replaced with those from EmojiOne)'
arch=('i686' 'x86_64')
url="https://desktop.telegram.org/"
license=('GPL3')
depends=('ffmpeg' 'hicolor-icon-theme' 'minizip' 'openal' 'qt5-base' 'qt5-imageformats')
-makedepends=('cmake' 'libappindicator-gtk3' 'dee' 'git' 'gyp-git' 'libexif' 'libva' 'libwebp' 'mtdev' 'python' 'python2')
-optdepends=('libappindicator-gtk3: AppIndicator tray icon')
+makedepends=('cmake' 'libappindicator-gtk2' 'dee' 'git' 'gtk3' 'gyp-git' 'libexif' 'libva' 'libwebp' 'mtdev' 'python' 'python2')
+optdepends=(
+ 'libappindicator-gtk3: AppIndicator tray icon'
+ 'libappindicator-gtk2: AppIndicator tray icon'
+)
conflicts=('telegram-desktop')
provides=('telegram-desktop')
install="telegram-desktop.install"
+_variant_ver="1.1.3"
+_GSL_commit="16a6a41690325433976d843e13ec676d6f9ab091"
+_libtgvoip_commit="757a5d8ec31aadcf387ac3cb135256152c18de1c"
source=(
"tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v$pkgver"
- "GSL::git+https://github.com/Microsoft/GSL.git"
- "variant::git+https://github.com/mapbox/variant.git"
+ "GSL::git+https://github.com/Microsoft/GSL.git#commit=${_GSL_commit}"
+ "variant::git+https://github.com/mapbox/variant#tag=v${_variant_ver}"
+ "libtgvoip::git+https://github.com/telegramdesktop/libtgvoip.git#commit=${_libtgvoip_commit}"
"telegramdesktop.desktop"
"tg.protocol"
- "Avoid-depending-on-static-libraries.patch"
- "Remove-Werror-flag.patch"
- "Downgrade-Qt-version.patch"
- "Flags-for-precompiled-header-and-MOC.patch"
- "Fix-rcc-path.patch"
- "Use-gtk3-headers.patch"
- "Reduce-number-of-libraries.patch"
- "Correct-MOC-path.patch"
"CMakeLists.inj"
- "qt_functions.cpp"
- "https://github.com/morealaz/tdesktop/raw/master/Telegram/Resources/art/emoji.webp"
- "https://github.com/morealaz/tdesktop/raw/master/Telegram/Resources/art/emoji_125x.webp"
- "https://github.com/morealaz/tdesktop/raw/master/Telegram/Resources/art/emoji_150x.webp"
- "https://github.com/morealaz/tdesktop/raw/master/Telegram/Resources/art/emoji_200x.webp"
- "https://github.com/morealaz/tdesktop/raw/master/Telegram/Resources/art/emoji_250x.webp"
+ "tdesktop.patch"
+ "libtgvoip.patch"
+ "https://github.com/morealaz/tdesktop/blob/master/Telegram/Resources/art/emoji.webp"
+ "https://github.com/morealaz/tdesktop/blob/master/Telegram/Resources/art/emoji_125x.webp"
+ "https://github.com/morealaz/tdesktop/blob/master/Telegram/Resources/art/emoji_150x.webp"
+ "https://github.com/morealaz/tdesktop/blob/master/Telegram/Resources/art/emoji_200x.webp"
+ "https://github.com/morealaz/tdesktop/blob/master/Telegram/Resources/art/emoji_250x.webp"
)
-
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'41c22fae6ae757936741e63aec3d0f17cafe86b2d6153cdd1d01a5581e871f17'
'd4cdad0d091c7e47811d8a26d55bbee492e7845e968c522e86f120815477e9eb'
- '8da40e3d8bbec2c8dc653cc8c5071b5a7a6e899befac75d6b996536703da4ce6'
- 'c47633e0c1e86cd4488c1533d5742245c5f9e910300f93083101d54597c00c3a'
- 'c05175c418354f3202f4a031ca4133769a37640c920e9e4ff91025f9fc58a015'
- '5b5a41a852d4d5b84466a19a04684dc7e43dfc6d6494dbcbe41341807bae52b3'
- 'cf4dbb293afdbfd226861a00a42790a15b23bea296eccf35853d104e07ea345a'
- '5f3ac7c08df0293bed626293dbfb6040764abf28899db7681572cfb1d8bcaa6e'
- '2990be2c71bdc6b8add19fb4d7638d03610989fe2c299c0ef776d526487deef1'
- '75dcda4aa2d6032f4931cf99e1d915defb4d960ee42725f3b54bbb7dd4ab8531'
'7a06af83609168a8eaec59a65252caa41dcd0ecc805225886435eb65073e9c82'
- '8fa4115ae60a87ee6c846f82d5cc4b90d0ba2b2016e1bd36634772230903af31'
- '304cdfa38e3471957241c41880e6c627cef617a862673788f647d8f84e561815'
- 'ed3e31591b2bbfa32a82a65d6a261f297ab9b5c26a17c1456483b17fd144e219'
- 'cc124ce04b79fdffc3ddb9e6abcd3b5d2f6510c398eeedf7e3d16fab22bd3e8c'
- '919674f30ef0ea660fbfb44e0f96068f01fdd28c73360f3ef46f39d597c7d9ea'
- '6f88da8d60136848770b35d63e8e625bcd2959714a3ec450ab5aeeae95cd84c8')
+ '6d54c8b51b2224c75c15d1e147855a6f22b96848ca3413330882ca6243dd05cb'
+ '640ef297f5977de78dab17789390e628b8f7a8a495529c24da8a43693f3fae23'
+ '41a30e53812d0da4a32a872193c3a53c05e455a4dfeed794944bc251edcae72d'
+ '8e3c254fcf4b57dcaf27f93dba0a59a5ff69382b018da424d9416a5c0577357c'
+ '558bb3082ba33d2547e4c5fb5f74639f0c10871648c7335a3cb652ac1fc08885'
+ 'cc040fa7d681bfc877dd0a32d4ce0df32bbcd80d78a7a8ae5721ddad71d79007'
+ 'c5fff9c7255c89b047bc6e9ba6e00b1f5788d895e564b80939165c333ce3ab68')
prepare() {
cd "$srcdir/tdesktop"
git submodule init
- git config submodule.third_party/GSL.url "$srcdir/GSL"
- git config submodule.third_party/variant.url "$srcdir/variant"
+ git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
+ git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
+ git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
git submodule update
- git apply "$srcdir/Avoid-depending-on-static-libraries.patch"
- git apply "$srcdir/Remove-Werror-flag.patch"
- git apply "$srcdir/Downgrade-Qt-version.patch"
- git apply "$srcdir/Flags-for-precompiled-header-and-MOC.patch"
- git apply "$srcdir/Fix-rcc-path.patch"
- git apply "$srcdir/Use-gtk3-headers.patch"
- git apply "$srcdir/Reduce-number-of-libraries.patch"
- git apply "$srcdir/Correct-MOC-path.patch"
+ patch -Np1 -i "$srcdir/tdesktop.patch"
+ pushd "Telegram/ThirdParty/libtgvoip"
+ patch -Np1 -i "$srcdir/libtgvoip.patch"
+ popd
for x in "" "_125x" "_150x" "_200x" "_250x"; do
cp "$srcdir/emoji$x.webp" "$srcdir/tdesktop/Telegram/Resources/art/emoji$x.webp"
done
- mkdir -p debian
- cp "$srcdir/qt_functions.cpp" debian/
}
build() {
@@ -113,6 +101,7 @@ package() {
local icon_size icon_dir
for icon_size in 16 32 48 64 128 256 512; do
icon_dir="$pkgdir/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps"
+
install -d "$icon_dir"
install -m644 "$srcdir/tdesktop/Telegram/Resources/art/icon${icon_size}.png" "$icon_dir/telegram-desktop.png"
done