summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 25 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 318e010a678f..978b65339497 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
-# $Id$
-# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor : Ionut Biru <ibiru@archlinux.org>
# Contributor: Daniel Balieiro <daniel@balieiro.com>
# Contributor: Rodrigo L. M. Flores <mail@rodrigoflores.org>
# Contributor: K900 <me@0upti.me>
@@ -7,39 +6,42 @@
# https://launchpad.net/~darkk/+archive/ubuntu/cisco-gabble
_pkgname=telepathy-gabble
pkgname=$_pkgname-cisco
-pkgver=0.18.3
+pkgver=0.18.4
pkgrel=1
pkgdesc="A Jabber/XMPP connection manager for Telepathy, patched to connect to Cisco Jabber servers"
-arch=('i686' 'x86_64')
-url="http://telepathy.freedesktop.org"
-groups=('telepathy')
-license=('LGPL2.1')
-depends=('telepathy-glib' 'libsoup' 'libnice' 'sqlite')
-makedepends=('libxslt' 'python2')
-options=('!emptydirs')
-source=(
- http://telepathy.freedesktop.org/releases/$_pkgname/$_pkgname-$pkgver.tar.gz
- cisco-jabber-workaround.patch
-)
+arch=(x86_64)
+url="https://telepathy.freedesktop.org"
+groups=(telepathy)
+license=(LGPL2.1)
+depends=(telepathy-glib libsoup libnice)
+makedepends=(libxslt python gnome-common)
+source=(https://telepathy.freedesktop.org/releases/telepathy-gabble/telepathy-gabble-$pkgver.tar.gz
+ cisco-jabber-workaround.patch
+ telepathy-gabble-0.18.4-python3.patch)
install=telepathy-gabble.install
-md5sums=('40f2fbabc4e6e147258c83ed697f2fcf'
- '23b47ce24f3701133cf806c06d73e79d')
-
+sha256sums=('115c91572c72d4a40f0b25b606167b4f2f09441dc7bf1036ccbb1450f1a4969c'
+ '1396e516e30394b0cbcc6fcd80e64fbfe8fa0929ce78130e85f66409785b1a45'
+ '2873cdb3b65deab1418acd25fc5ec4bf120f52dcceda129ae7ac315026ea2749')
provides=('telepathy-gabble')
conflicts=('telepathy-gabble')
-build() {
+prepare() {
cd $_pkgname-$pkgver
+ patch -p1 -i ../cisco-jabber-workaround.patch
+ # port to python3, patch taken from Fedora
+ patch -Np1 -i ../telepathy-gabble-0.18.4-python3.patch
+}
- patch -p1 -i $srcdir/cisco-jabber-workaround.patch
-
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr \
- --libexecdir=/usr/lib/telepathy --with-tls=openssl
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/telepathy \
+ --disable-Werror --enable-gtk-doc
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
cd $_pkgname-$pkgver
make DESTDIR="$pkgdir" install
- sed -i "s|#!/usr/bin/env python|#!/usr/bin/env python2|" "$pkgdir/usr/bin/telepathy-gabble-xmpp-console"
}