summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 27 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ab48381bcdd..aa2cc5c6ca1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,49 @@
-# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
-_pkgname=tepl
-pkgname="${_pkgname}-git"
-pkgver=6.5.1+2+ga58b1fb
+pkgname=tepl-git
+pkgver=6.9.0.r4.gdec59c9
pkgrel=1
-_pkgdesc=("Library that eases the development of GtkSourceView-based "
- "text editors and IDEs")
-pkgdesc="${_pkgdesc[@]}"
+pkgdesc="Library that eases the development of GtkSourceView-based text editors and IDEs"
arch=(x86_64)
-url="https://gitlab.gnome.org/swilmet/${_pkgname}"
+url="https://gitlab.gnome.org/swilmet/tepl"
license=(LGPL2.1)
depends=(
- 'amtk'
- 'cairo'
- 'glib2'
- 'glibc'
- 'gsettings-desktop-schemas'
- 'gtk3'
- 'gtksourceview4'
- 'icu'
- 'pango'
+ libgedit-amtk
+ cairo
+ glib2
+ glibc
+ gsettings-desktop-schemas
+ gtksourceview4
+ icu
+ pango
+ libhandy
+ libgedit-gtksourceview-git
)
makedepends=(
- 'git'
- 'gobject-introspection'
- 'gtk-doc'
- 'meson'
+ git
+ gobject-introspection
+ gtk-doc
+ meson
)
-provides=("${_pkgname}=${pkgver}")
-conflicts=("${_pkgname}")
+checkdepends=(xorg-server-xvfb)
+provides=("tepl=${pkgver}")
+conflicts=(tepl)
source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- git describe --tags | sed 's/-/+/g'
+ cd "tepl"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson "${_pkgname}" build
+ arch-meson "tepl" build
meson compile -C build
}
check() {
- xvfb-run -s '-screen 0 1920x1080x24 -nolisten local' \
- meson test -C build --print-errorlogs
+ xvfb-run -s '-screen 0 1920x1080x24 -nolisten local' meson test -C build --print-errorlogs
}
package() {