summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f151751c3fa..46cd992e2abf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Contributor: Dragonlord <archlinux[at]dragonlord[.]cz>
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
pkgname=throttle
pkgver=1.2
pkgrel=1
-pkgdesc="Copies the standard input to the standard output while limiting bandwidth to the specified maximum."
-arch=('i686')
+pkgdesc="Copies the standard input to the standard output while limiting bandwidth to the specified maximum"
+arch=('i686' 'x86_64')
url="http://klicman.org/throttle/"
license=('GPL')
-depends=('glibc')
-source=(http://klicman.org/$pkgname/$pkgname-$pkgver.tar.gz)
-
+source=(ftp://ftp.fi.freebsd.org/pub/FreeBSD/ports/distfiles/$pkgname-$pkgver.tar.gz)
md5sums=('bb8abf5a9a63ed7d80951f056543a88c')
build() {
- cd "$startdir/src/$pkgname-$pkgver"
+ cd "${srcdir}"/$pkgname-$pkgver
./configure --prefix=/usr --mandir=/usr/share/man
- make || return 1
- make DESTDIR="$startdir/pkg" install
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ make DESTDIR="${pkgdir}" install
}